[syslinux] Intel DX79TO localboot problem with CentOS

H. Peter Anvin hpa at zytor.com
Mon Aug 5 23:22:17 PDT 2013


What about "chain.c32 hd1" or "chain.c32 hd1 swap"?

Jonas Keidel <jonas at jonas-keidel.de> wrote:
>2013/8/5 Jonas Keidel <jonas at jonas-keidel.de>
>
>>
>>
>> 2013/8/5 H. Peter Anvin <hpa at zytor.com>
>>
>>> On 08/05/2013 07:04 AM, Jonas Keidel wrote:
>>>
>>> >
>>> > So i've also tried to use chain.c32, but there are also some
>problems.
>>> > For example FreeBSD doesn't boot with chain.c32, so we've decided
>to use
>>> > localboot, because it works in 90%, except with that board.
>>> > Maybe you have an idea how to fix that? Or what do you think is
>broken?
>>> >
>>>
>>> It would be a BIOS problem.  There might be a BIOS update.
>>>
>>
>> I've installed the latest bios from their website on the board.
>>
>>
>>>
>>> "localboot -1" might work on your other systems as well... hard to
>know.
>>>
>>
>> No it doesn't, i think, because if that would be so we will be using
>it.
>>
>>
>>>
>>> FreeBSD not booting with chain.c32 is a surprise.
>>>
>>>
>> We've tested that on several machines and yes, it does not boot. So
>we
>> changed back to localboot.
>>
>
>so further information towards the chain.c32 problem:
>we can't boot from a software raid with this, because if the first hdd
>is
>swapped (and empty), the system normally can boot from the secondary
>hdd.
>But with chain.c32 that isn't possible.
>So we need localboot working.
>
>
>>
>>
>>>          -hpa
>>>
>>>
>>>
>>

-- 
Sent from my mobile phone. Please excuse brevity and lack of formatting.


More information about the Syslinux mailing list